Scheduled for January 05, 2026 at 3:50 PM – 6:50 PM
Affects
Distamus
Under maintenance from 3:50 PM to 6:50 PM
Completed
January 05, 2026 at 6:50 PMCompleted
January 05, 2026 at 6:50 PMMaintenance has completed successfully
In progress
January 05, 2026 at 3:50 PMIn progress
January 05, 2026 at 3:50 PMMaintenance is now in progress
Planned
January 05, 2026 at 3:50 PMPlanned
January 05, 2026 at 3:50 PMEstamos completando las últimas páginas de Distamus Home como parte del mantenimiento activo del sitio. Algunas secciones pueden experimentar cambios visuales o de navegación.